CalDAV
| CalDAV | |
|---|---|
| aufbauend auf | WebDAV |
| Einführung: | März 2007 |
| Standard: | RFC 4791<ref name="RFC4791" /> |
CalDAV (Calendar Distributed Authoring and Versioning) ist ein Netzwerkprotokoll für iCalendar.
Beschreibung[Bearbeiten]
Die CalDAV-Spezifikation wurde erstmals 2003 von Lisa Dusseault als Entwurf an die Internet Engineering Task Force (IETF) übermittelt und bekam schnell die Unterstützung einiger Hersteller von Kalendersoftware. Im Januar 2005 erfolgte erstmals ein Test zwischen zwei Servern und drei Clients; diese arbeiteten erfolgreich zusammen. CalDAV hat keine eigene IETF-Arbeitsgruppe, aber die Entwickler haben es dennoch als IETF-Standard RFC 4791 Calendaring Extensions to WebDAV (CalDAV)<ref name="RFC4791" /> publiziert. CalDAV ist für die Implementierung in jegliche Kalendersoftware entwickelt worden. Dabei verwaltet das CalDAV-Protokoll die Zugriffe auf die Daten nach fest definierten Zugriffsregeln. Es wurde als offener Standard ausgeführt, um eine plattformunabhängige Nutzung zu fördern.
Die Aufgabe von CalDAV ist es, Ereignisse wie Treffen, Versammlungen sowie die Frei-/Belegt-Zeiten zu verwalten und über HTTP zu veröffentlichen. Jedes Ereignis wird im iCalendar-Format dargestellt. Demzufolge kann jeder Webbrowser ein heruntergeladenes Ereignis in seiner iCalendar-Repräsentation darstellen. Die Daten werden als Datensätze in einer WebDAV-Umgebung verwaltet und synchronisiert.
CalDAV-Server müssen iCalendar (RFC 2445<ref name="RFC2445" />), WebDAV (RFC 2518<ref name="RFC2518" />) mit Versioning Extensions (RFC 3253<ref name="RFC3253" />) und Access Control Lists (RFC 3744<ref name="RFC3744" />), ETags (RFC 2616<ref name="RFC2616" />), Transport Layer Security (RFC 2818<ref name="RFC2818" />) und CalDav eigene Reports anbieten und sollen das CalDav eigene Erstellen von Kalendern anbieten.<ref name="RFC4791-2" /> Mit dieser Funktionalität kann ein Benutzer seinen Kalender mit einem CalDAV-Server synchronisieren und ihn mit mehreren Geräten oder anderen Benutzern teilen. Das Protokoll unterstützt auch die Veröffentlichung von nicht-personenbezogenen Kalendern, wie z. B. von Räumen oder Organisationen.
Einige Entwickler haben die Komplexität von CalDAV kritisiert, da es schwer zu implementieren ist und so zu Implementierungsfehlern in unterschiedlichen Kalenderverwaltungsanwendungen führen kann, die wiederum zu Inkompatibilitäten führen.
Aktuelle CalDAV-Informationen können auf der CalDAV-Webseite<ref>CalDAV-Website</ref> nachgelesen werden.
Beispiel[Bearbeiten]
Das Beispiel basiert auf dem RFC 4791<ref name="RFC4791" /> und wurde dem Linux-Magazin entnommen<ref>Markus Feilner: [Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden.] In: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Archiviert vom Vorlage:Referrer (nicht mehr online verfügbar) am 21. Oktober 2009; abgerufen am 3. Juni 2010.</ref>:
Anfrage: <syntaxhighlight lang="http"> REPORT /bernard/work/ HTTP/1.1 Host: cal.example.com Depth: 1 Content-Type: application/xml; charset="utf-8" Content-Length: xxxx </syntaxhighlight>
<syntaxhighlight lang="xml"> <?xml version="1.0" encoding="utf-8"?> <C:free-busy-query xmlns:C="urn:ietf:params:xml:ns:caldav"> <C:time-range start="20060104T140000Z" end="20060105T220000Z"/> </C:free-busy-query> </syntaxhighlight>
Antwort: <syntaxhighlight lang="http"> HTTP/1.1 200 OK Date: Sat, 11 Nov 2006 09:32:12 GMT Content-Type: text/calendar Content-Length: xxxx </syntaxhighlight>
<syntaxhighlight lang="ics" kommentar="pygments kennt ics nicht, also:" lang="ini"> BEGIN:VCALENDAR VERSION:2.0 PRODID:-//Example Corp.//CalDAV Server//EN BEGIN:VFREEBUSY DTSTAMP:20050125T090000Z DTSTART:20060104T140000Z DTEND:20060105T220000Z FREEBUSY;FBTYPE=BUSY-TENTATIVE:20060104T150000Z/PT1H FREEBUSY:20060104T190000Z/PT1H END:VFREEBUSY END:VCALENDAR </syntaxhighlight>
Software[Bearbeiten]
Client[Bearbeiten]
Die Liste der CalDAV-Clients<ref>Vorlage:Cite book/Name: [Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden.] In: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. , archiviert vom Vorlage:Referrer (nicht mehr online verfügbar) am Vorlage:Cite book/URL; abgerufen am 10. Mai 2023 (Lua-Fehler in Modul:Multilingual, Zeile 153: attempt to index field 'data' (a nil value)).Vorlage:Cite book/URLVorlage:Cite book/MeldungVorlage:Cite book/Meldung2Vorlage:Cite book/MeldungVorlage:Cite book/MeldungVorlage:Cite book/MeldungVorlage:Cite book/MeldungVorlage:Cite book/Meldung</ref> enthält unter anderem:
- AgenDAV (Open Source multilanguage CalDAV WebClient mit AJAX interface)
- Atmail (ab Version 6.0)
- CalendarSync für Android<ref name="CalendarSync">CalendarSync</ref>
- CalDAV Tasksync für Android<ref name="TaskSync">TaskSync</ref>
- CalDAV-Sync für Android<ref name="CalDAV-Sync">CalDAV-Sync</ref>
- CalDavZAP (Webbasierte HTML5/JavaScript-Anwendung, Open Source)<ref name="CalDavZAP">CalDavZAP</ref>
- DAVx5 für Android (Open Source; vorheriger Name DAVdroid)<ref name="DAVx5">DAVx5</ref> und ICSx⁵ für iCal-Abos<ref>ICSx⁵</ref>
- Business Kalender 2 (Android)<ref name="Business Kalendar 2">Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Abgerufen am 16. September 2025.</ref>
- eM Client (Windows)
- Evolution (Linux, Unix)
- Horde Groupware<ref name="horde">Horde Groupware</ref>
- iCal (ab Mac OS X Leopard – 10.5)
- iCal Import/Export CalDAV für Android<ref name="iCal Import/Export CalDAV">iCal Import/Export CalDAV</ref>
- iPhone (ab Version 3.0 oder ab Version 2.1 mit RemoteCalendar)
- khal (Konsolenanwendung, Linux, Mac OS X)<ref>pimutils/khal github.com</ref>
- KOrganizer (Kalender-Anwendung von KDE)
- Microsoft Outlook (Classic) mit
- Bynari WebDAV Collaborator<ref><templatestyles src="Webarchiv/styles.css" />Der Wert des Parameters
archive-todaymuss ein Datum der Form YYYYMMDD oder Zeitstempel der Form YYYY.MM.DD-hhmmss bzw. YYYYMMDDhhmmss sein. bynari.net (englisch).</ref> - Caldav Outlook Synchronizer (Open Source)
- Calendar Sync + (Open Source)
- cFos Outlook DAV<ref>cFos Outlook DAV (>= Outlook 2010)</ref>
- EVO Collaborator for Outlook<ref>EVO Collaborator for Outlook</ref>
- iCAL4OL (eingestellt)<ref>iCAL4OL (nicht mehr für Neukunden erhältlich)</ref>
- SOGo (früher Scalable OpenGroupware.org)
- Outlook Caldav Synchronizer (Open Source)<ref>Outlook CalDav Synchronizer. sourceforge.net</ref>
- Bynari WebDAV Collaborator<ref><templatestyles src="Webarchiv/styles.css" />Der Wert des Parameters
- Mozilla Thunderbird<ref>Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Universität Bielefeld, abgerufen am 28. Dezember 2024.</ref>
- Parula
Server[Bearbeiten]
CalDAV-Server sind unter anderem:
- Apple iCal Server<ref name="Server">Vorlage:Cite book/Name: [Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden.] , archiviert vom Vorlage:Referrer (nicht mehr online verfügbar) am Vorlage:Cite book/URL; abgerufen am 28. Dezember 2024 (Lua-Fehler in Modul:Multilingual, Zeile 153: attempt to index field 'data' (a nil value)).Vorlage:Cite book/URLVorlage:Cite book/MeldungVorlage:Cite book/Meldung2Vorlage:Cite book/MeldungVorlage:Cite book/MeldungVorlage:Cite book/MeldungVorlage:Cite book/MeldungVorlage:Cite book/Meldung</ref>
- Atmail (ab Version 6.0)
- Baïkal<ref name="Server" />
- Bedework<ref name="Server" />
- Bynari Collaboration Suite<ref name="Server" />
- CommuniGate Pro<ref name="Server" />
- Cosmo aus Chandler (1&1, GMX, WEB.DE, mail.com)<ref name="Server" /><ref>Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Abgerufen am 28. Dezember 2024.</ref>
- Cyrus<ref name="Server" />
- DAViCal<ref name="Server" />
- DavMail<ref name="Server" />
- Daylite CalDAV Server<ref name="Server" />
- DPCalendar<ref name="Server" />
- EGroupware<ref name="Server" />
- EVO Mail Server<ref name="Server" />
- Fabasoft Cloud
- Google Kalender (Aufgaben ausgenommen)<ref>Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Mozilla Corporation, abgerufen am 28. Dezember 2024.</ref>
- Horde Groupware<ref name="horde" />
- Icewarp-E-Mail-Server ab der Version 8.x
- IT Hit WebDAV Server Engine for .Net
- Kerio Connect<ref name="Server" />
- GroupWise
- mod_caldav<ref>mod_caldav SourceForge.</ref>
- Nextcloud
- Open-Xchange
- Oracle Beehive
- Oracle Communications Calendar Server<ref name="Server" />
- ownCloud<ref name="Server" />
- Radicale<ref name="Server" />
- sabre/dav<ref name="Server" />
- SOGo<ref name="Server" />
- Scalix<ref name="Server" />
- sync•gw<ref>Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. GitHub, 2. Oktober 2023, abgerufen am 14. Februar 2024.</ref>
- Synovel CollabSuite<ref>Falko Benthin: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. In: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. 18. Januar 2008, abgerufen am 11. November 2024.</ref>
- Yahoo Kalender<ref>Thema CalDAV. Yahoo-Hilfe.</ref>
- Zarafa ab der Version 6.30.0
- Zimbra<ref name="Server" />
- Mailfence<ref>Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Mailfence, abgerufen am 9. April 2020 (Lua-Fehler in Modul:Multilingual, Zeile 153: attempt to index field 'data' (a nil value)).</ref>
Siehe auch[Bearbeiten]
- CardDAV zur Kontaktdaten-Synchronisation
Weblinks[Bearbeiten]
- [Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden.] In: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. Archiviert vom Vorlage:Referrer am 6. Juli 2024 (Lua-Fehler in Modul:Multilingual, Zeile 153: attempt to index field 'data' (a nil value)).
- Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. In: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. (Lua-Fehler in Modul:Multilingual, Zeile 153: attempt to index field 'data' (a nil value)).
- Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. In: Skriptfehler: Ein solches Modul „Vorlage:Internetquelle“ ist nicht vorhanden. (Lua-Fehler in Modul:Multilingual, Zeile 153: attempt to index field 'data' (a nil value)).
Einzelnachweise[Bearbeiten]
<references responsive> <ref name="RFC2445"> Vorlage:RFC-Internet </ref> <ref name="RFC2518"> Vorlage:RFC-Internet </ref> <ref name="RFC2616"> Vorlage:RFC-Internet </ref> <ref name="RFC2818"> Vorlage:RFC-Internet </ref> <ref name="RFC3253"> Vorlage:RFC-Internet </ref> <ref name="RFC3744"> Vorlage:RFC-Internet </ref> <ref name="RFC4791"> Vorlage:RFC-Internet </ref> <ref name="RFC4791-2"> Vorlage:RFC-Internet </ref> </references>